Após fazer um resumo da parte teórica do RIP, vamos ver como realizar a configuração deste protocolo. A configuração básica do RIP é simples, sendo necessário habilitar o roteamento e divulgar as redes, apenas.
Abaixo segue um exemplo onde foram utilizados um roteador 2801, um switch 3550 e um switch 3750, e o objetivo era fazer o roteador aprender todas as redes e divulgar as suas (1.0.0.0 e 192.168.20.0).
Configuração 2801:
conf t
router rip
network 1.0.0.0
network 192.168.20.0Configuração 3750:
conf t
router rip
network 172.16.0.0
network 172.19.0.0
network 192.168.20.0Configuração 3550:
conf t
router rip
network 172.16.0.0
network 172.18.0.0
network 192.168.1.0
Após essa configuração cada roteador/switch enviará suas rotas e receberá as dos demais, trabalhando com as features padrões (versão 1, sem autenticação, sumarização automática, timers padrões,…).
Lembre-se que o RIPv1 é um protocolo classfull, assim ele considera sempre a máscara padrão. Mesmo que sejam configuradas as redes 172.16.1.0, 172.18.1.0 e 172.19.1.0 no processo de roteamento, elas serão convertidas para 172.16.0.0, 172.18.0.0 e 172.19.0.0.
Verificação da configuração
Para verificar o funcionamento do RIP, além do show run, que mostrará as configurações realizadas, podemos ver se as rotas foram aprendidas com o comando show ip route. Outras informações podem ser encontradas usando os comandos show ip protocols e show ip rip database.
2801#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static routeGateway of last resort is 192.168.20.1 to network 0.0.0.0
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, FastEthernet0/1
R 172.16.0.0/16 [120/1] via 192.168.20.1, 00:00:15, FastEthernet0/0
R 172.19.0.0/16 [120/1] via 192.168.20.1, 00:00:15, FastEthernet0/0
R 172.18.0.0/16 [120/1] via 192.168.20.1, 00:00:15, FastEthernet0/0
192.168.20.0/30 is subnetted, 1 subnets
C 192.168.20.0 is directly connected, FastEthernet0/0
R 192.168.1.0/24 [120/1] via 192.168.20.1, 00:00:16, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 192.168.20.1
2801#2801#show ip protocols
Routing Protocol is “rip”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 24 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 1 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
1.0.0.0
192.168.20.0
Routing Information Sources:
Gateway Distance Last Update
192.168.20.1 120 00:00:09
Distance: (default is 120)2801#show ip rip database
1.0.0.0/8 auto-summary
1.1.1.0/24 directly connected, FastEthernet0/1
172.16.0.0/16 auto-summary
172.16.0.0/16
[1] via 192.168.20.1, 00:00:23, FastEthernet0/0
172.18.0.0/16 auto-summary
172.18.0.0/16
[1] via 192.168.20.1, 00:00:23, FastEthernet0/0
172.19.0.0/16 auto-summary
172.19.0.0/16
[1] via 192.168.20.1, 00:00:23, FastEthernet0/0
192.168.1.0/24 auto-summary
192.168.1.0/24
[1] via 192.168.20.1, 00:00:23, FastEthernet0/0
192.168.20.0/24 auto-summary
192.168.20.0/30 directly connected, FastEthernet0/0
2801#
Caso algum problema seja percebido, podemos utilizar o comando debug ip rip para ver os updates enviados e recebidos.
2801#debug ip rip
*Oct 7 11:23:49.024: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.20.2)
*Oct 7 11:23:49.024: RIP: build update entries
*Oct 7 11:23:49.024: network 1.0.0.0 metric 1
2801#
*Oct 7 11:23:56.648: RIP: received v1 update from 192.168.20.1 on FastEthernet0/0
*Oct 7 11:23:56.648: 172.16.0.0 in 1 hops
*Oct 7 11:23:56.648: 172.18.0.0 in 1 hops
*Oct 7 11:23:56.648: 172.19.0.0 in 1 hops
*Oct 7 11:23:56.648: 192.168.1.0 in 1 hops
2801#
*Oct 7 11:24:04.268: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/1 (1.1.1.1)
*Oct 7 11:24:04.268: RIP: build update entries
*Oct 7 11:24:04.268: network 172.16.0.0 metric 2
*Oct 7 11:24:04.268: network 172.18.0.0 metric 2
*Oct 7 11:24:04.268: network 172.19.0.0 metric 2
*Oct 7 11:24:04.268: network 192.168.1.0 metric 2
*Oct 7 11:24:04.268: network 192.168.20.0 metric 1
2801#
*Oct 7 11:24:16.000: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.20.2)
*Oct 7 11:24:16.000: RIP: build update entries
*Oct 7 11:24:16.000: network 1.0.0.0 metric 1
2801#
Passive Interface
Como podemos ver na topologia acima, uma das interfaces (F0/1) do roteador 2801 está conectada a um PC, assim, esta interface não precisa enviar os updates.
Para configurar uma interface como passiva, devemos indicá-la dentro do processo de roteamento.
No 2801 digite:
conf t
router rip
passive-interface f0/1
Com este comando os updates do RIP não serão enviados pela interface F0/1. No entanto ela continuará “ouvindo”.
Até a próxima.