CREATE ACCOUNT

FORGOT YOUR DETAILS?

Comandos básicos para roteadores Cisco

by / quarta-feira, 13 janeiro 2010 / Published in Cisco, Configuração, Dicas, IOS, Routers, Uteis

Este post deveria ter sido um dos primeiros no blog… mas como dizem, antes tarde do que nunca.

Coloquei os comandos básicos/úteis para utilização no Cisco IOS, via CLI – Command Line Interface. Acredito que vai ser bem útil para que está começando, ou acessa o roteador apenas eventualmente.

Modos de Configuração
roteador>
-  Modo Usuário
roteador# -  Modo Privilegiado
roteador(config)# -  Modo Global

Modo Usuário
enable
-  Entra no modo de configuração privilegiado

Modo Privilegiado
? -  Mostra os comandos disponíveis
configure terminal -  Entra no modo de configuração global
clock set – Configura a data e hora no equipamento
delete flash:/nome_do_arquivo -  Apaga o arquivo da flash
dir -  Mostra o conteúdo da flash
disable -  Sai do modo de configuração privilegiado
erase flash -  Apaga todo o conteúdo da flash
erase nvram -  Apaga todo o conteúdo da nvram
ping 10.1.1.1 – Pinga o host 10.1.1.1 e mostra o resultado
reload – Reinicia o roteador
traceroute 172.16.1.1 -  Mostra o caminho até o IP 172.16.1.1

Modo configuração global
enable secret -  Define a senha de enable
hostname  –
Define o "nome" no roteador
interface f0/0 – Entra no modo de configuração da interface fastethernet 0/0
ip route 0.0.0.0 0.0.0.0 10.1.1.1 -  cria uma rota padrão para 10.1.1.1
ip route 192.168.0.0 255.255.255.0 172.16.1.1 – cria uma rota estática para a rede 192.168.0.0, através de 172.16.1.1

Modo Configuração de Interface
description -  Coloca uma descrição na interface
end -  Volta para o modo privilegiado
exit -  Sai do modo de configuração de Interface
ip address 5.5.5.5 255.255.255.0 -  Configura o IP e máscara na interface
shutdown -  Desabilita a interface
no shutdown – Habilita a interface

Verificação básica
show arp -  Mostra a tabela arp do roteador
show diag -  Mostra informações dos módulos
show history -  Mostra os últimos comandos digitados
show version -  Mostra a versão do IOS e informações de hardware
show running-config -  Mostra a configuração
show interface -  Mostra informações das interfaces
show ip interface -  Mostra informações do protocolo IP na interface
show ip route -  Mostra a tabela de rotas
show users -  Mostra os usuários conectados
show tech-support -  Informação completa do sistema

Salvando a configuração
copy running-config startup-config
-  Salva configuração da memória DRAM para NVRAM
copy running-config tftp: -  Salva configuração da memória DRAM para o servidor TFTP
copy tftp: running-config -  Salva configuração do servidor TFTP para memória DRAM
wr -  Salva configuração da memória DRAM para NVRAM

Esta lista de comandos, mais as teclas de atalhos (publicadas em outro post) estão neste wallpaper, para quem quiser baixar.

Wallpaper CLI

Até a próxima.

115 Responses to “Comandos básicos para roteadores Cisco”

  1. Lucas says : Responder

    Como faço para resetar todo o meu roteador? Quero colocar ele como novo de fabrica. Ele é um cisco 1700.

  2. Lucas, basta dar um erase startup. Em seguida de o comando reload, e quando ele perguntar se você quer salvar a configuração você digita “N”.
    Para outra questões você pode usar também o http://www.brainwork.com.br/qa.

  3. Emerson says : Responder

    Ótimo post!
    Amigo tenho uma dúvida, fiz o comando para resetar a IOS do Cisco para as configurações de fábrica.
    Depois desse procedimento, quando tento criar rotas no router, essas rotas não aparecem, será que estraguei o IOS?

  4. Não acho que você tenha estragado o IOS Emerson.
    Como você está criando rotas? Onde elas não aparecem?
    Coloque os comandos que você está usando.

  5. jair says : Responder

    quando a NVRAM apresenta checksum, indicando falhas, que posso fazer? A NVRAM pertence a um chip da placa mae do CISCO 2500?

  6. Jair, em alguns equipamentos da para trocar a NVRAM, não sei se é o caso do 2500.
    Você também pode substituir a NVRAM por um TFTP server, assim o roteador vai buscar o IOS e o startup-config (arquivo de configuração) no TFTP. Veja este post
    http://brainwork.com.br/blog/2011/08/23/carregando-o-ios-de-um-servidor-tftp/

  7. Dener Santos says : Responder

    Parabéns pelo topico André!
    Preciso trocar a mascara de um 1841, como faria?

  8. Dener, basta entrar na interface e configurar o ip/máscara.
    Ex:
    conf t
    int f0/0 (escolha a interface)
    ip add 10.0.0.1 255.255.255.0 (coloque o ip/máscara que você precisa)

    Você pode usar o brainwork responde para essa e outras dúvidas.

  9. Manoel Américo Zancheta says : Responder

    Olá.

    Por favor, me tire uma dúvida.

    Eu tenho um roteador 1841 da Cisco, ainda não o uso. Meu sinal aqui é Speedy com IP dinâmico. Dá pra configurar o roteador com este tipo de sinal ou o IP do ADSL tem que ser fixo?

  10. Dá para usar IP dinâmico sim.

  11. Manoel Américo Zancheta says : Responder

    obrigado por responder… recebi uma informação de que speedy não funciona com roteador 1841, procede isso.

    ps- não sei se vc atentou pelo fato de ser Speedy…

  12. Não vejo problema, já utilizei inclusive… o que acontece é que você vai precisar de um modem em modo brigde, pois o 1841, por padrão, não tem porta RJ11.

    Você também pode usar o brainwork responde para tirar dúvidas.

  13. Manoel Américo Zancheta says : Responder

    entendi…

    pô valeu cara, obrigado pelas suas dicas, poucas são as pessoas que compartilham o conhecimento.

    um grande abraço!!!

  14. César Winter says : Responder

    Muito bom esse post me ajudou muito….
    Vlw

  15. Nelson says : Responder

    O roteador 2500 cisco possui algum registro de log?
    Se possui como eu acho essas informações?

  16. Paulo says : Responder

    Tenho um roteador cisco 1700, mas não lembro a senha de admin dele, tem alguma foma de descobrir?

  17. AlanS says : Responder

    Parabéns pelas dicas… rápidas e diretas!
    Mas estou fazendo uns testes no packet tracer para estudar e não estou conseguindo estabelecer uma rota entre duas redes…

    REDE 1:
    10.0.0.0
    255.0.0.0
    PC1 10.0.0.1
    PC2 10.0.0.2

    REDE 2:
    192.168.0.0
    255.255.255.0
    PC1 192.168.0.1
    PC2 192.168.0.2

    Os PCs de cada rede estão na Switch e o roteador estão ligando estas.

    Quero criar uma rotas para uma rede enxergar a outra…
    Sei que é uma dúvida bem iniciante, mas estou aprendendo… Alguma dica?
    Agradeço muito! Abraço.

  18. Quem é o gateway de cada rede? Basta você configurar os gateways dos PCs com o IP da interface do roteador.

  19. Deco says : Responder

    Boa noite,
    estou precisando de ajuda para configuar um AP1200 Cisco, se alguem puder me da uma força eu agradeço, nao manjo desse equipamento comprei de um amigo e resetei ele, e nao consigo acessar via browser com o ip 10.0.0.1?
    conectei o cabo console e aparece esse comando abaixo sem eu digitar nada somente dou um ? não deveria aparecer ap:? desde já agradeço;
    ….
    roduct/Model Number : AIR-AP1231G-A-K9
    Press RETURN to get started!

    *Mar 1 00:00:06.061: %SYS-5-RESTART: System restarted —
    Cisco IOS Software, C1200 Software (C1200-RCVK9W8-M), Version 12.3(11)JX1, RELEA
    SE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by Cisco Systems, Inc.
    Compiled Mon 17-Jul-06 11:41 by alnguyen
    *Mar 1 00:00:06.978: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to
    up
    *Mar 1 00:00:07.978: %LINEPROTO-5-UPDOWN: Line protocol on
    Interface FastEthern
    et0, changed state to down
    CEO_Meeting_2011>
    *Mar 1 00:00:25.072: %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY
    CEO_Meeting_2011>

  20. Olá Deco,

    Aparentemente o equipamento não procedeu com o Reset, quais foram os procedimentos que você realizou para executar o Reset?

    A propósito você pode utilizar nosso sistema de Perguntas e Respostas ( http://brainwork.com.br/qa ) para estas questões.

    Abs,

    Leandro Oliveira

  21. Deco says : Responder

    Olá Leandro, obrigado pelo retorno e estarei utilizando o sistema de perguntas e respostas obrigado.Quanto ao procedimento foi esse descrito abaixo que peguei no site da Cisco Aironet 1200 series:

    Step 1 Disconnect power (the power jack for external power or the Ethernet cable for in-line power) from the
    access point.
    Step 2 Press and hold the MODE button while you reconnect power to the access point.
    Step 3 Hold the MODE button until the Status LED turns amber (approximately 1 to 2 seconds), and release the
    button. All access point settings return to factory defaults.
    ………….Foi basicamente isso que eu fiz>Desliguei o cabo de alimentação com o botao mode pressionado liguei novamente a alimentação com o botao mode pressionado e soltei em 3 a 5 segundos……Depois do suposto reset ele deu essa menssagem vou copiar e colar aqui só para vc analizar se possível; me parece que diz que tá com pau na inicialização….de algo ai valeu!
    Xmodem file system is available.
    flashfs[0]: 12 files, 3 directories
    flashfs[0]: 0 orphaned files, 0 orphaned directories
    flashfs[0]: Total bytes: 7741440
    flashfs[0]: Bytes used: 5570560
    flashfs[0]: Bytes available: 2170880
    flashfs[0]: flashfs fsck took 17 seconds.
    Reading cookie from flash parameter block…done.
    Base ethernet MAC Address: 00:19:2f:ae:de:32
    Initializing ethernet port 0…
    Reset ethernet port 0…
    Reset done!
    link auto-negotiating….
    auto-negotiation takes 10000 milli-seconds to complete
    ERROR: timeout waiting for auto-negotiation to complete
    ERROR: fail to bring ethernet link up

    The system has been encountered an error initializing
    ethernet port. You may need to check hardware
    The system is ignoring the error and continuing boot.
    If you interrupt the system boot process, the following
    commands will reinitialize ethernet, tftp, and finish
    loading the operating system software:

    ether_init
    tftp_init
    boot

    button pressed for 2 seconds
    process_config_recovery: set IP address and config to default 10.0.0.1
    Loading “flash:/c1200-rcvk9w8-mx/c1200-rcvk9w8-mx”…###########################
    ################################################################################
    ##############################################################

    File “flash:/c1200-rcvk9w8-mx/c1200-rcvk9w8-mx” uncompressed and installed, entr
    y point: 0x3000
    executing…

    Restricted Rights Legend

    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software – Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.

    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706

    Cisco IOS Software, C1200 Software (C1200-RCVK9W8-M), Version 12.3(11)JX1, RELEA
    SE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by Cisco Systems, Inc.
    Compiled Mon 17-Jul-06 11:41 by alnguyen
    Image text-base: 0x00003000, data-base: 0x00359FC0

    Initializing flashfs…

    flashfs[1]: 12 files, 3 directories
    flashfs[1]: 0 orphaned files, 0 orphaned directories
    flashfs[1]: Total bytes: 7741440
    flashfs[1]: Bytes used: 5570560
    flashfs[1]: Bytes available: 2170880
    flashfs[1]: flashfs fsck took 3 seconds.
    flashfs[1]: Initialization complete….done Initializing flashfs.
    cisco AIR-AP1231G-A-K9 (PowerPC405GP) processor (revision A0) with 15038K/13
    36K bytes of memory.
    Processor board ID FTX1040R02U
    PowerPC405GP CPU at 196Mhz, revision number 0x0145
    Last reset from power-on
    LWAPP image version 3.0.51.0
    1 FastEthernet interface

    32K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:19:2F:AE:DE:32
    Part Number : 73-8704-12
    PCA Assembly Number : 800-23211-13
    PCA Revision Number : A0
    PCB Serial Number : FOC103739VN
    Top Assembly Part Number : 800-23304-13
    Top Assembly Serial Number : FTX1040R02U
    Top Revision Number : B0
    Product/Model Number : AIR-AP1231G-A-K9

    Press RETURN to get started!

    *Mar 1 00:00:06.060: %SYS-5-RESTART: System restarted —
    Cisco IOS Software, C1200 Software (C1200-RCVK9W8-M), Version 12.3(11)JX1, RELEA
    SE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by Cisco Systems, Inc.
    Compiled Mon 17-Jul-06 11:41 by alnguyen
    *Mar 1 00:00:06.977: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to
    up
    *Mar 1 00:00:07.977: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern
    et0, changed state to down
    *Mar 1 00:00:25.072: %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY
    CEO_Meeting_2011>

  22. Deco, pela última linha do log, este AP está com o software “LWAPP”, ou seja: ele só trabalha com uma controladora

    Para usar ele no modo autônomo, e poder acessar a interface de configuração você vai precisar fazer o procedimento indicado no link abaixo e trocar o software.

    http://www.cisco.com/en/US/docs/wireless/access_point/conversion/lwapp/upgrade/guide/lwapnote.html#wp161272

  23. Deco says : Responder

    Boa noite André,resolvido fiz o procedimento agora aparece o ap> Valeu!!! mesmo e parabéns pela iniciativa de sempre multiplicar o conhecimento…Abraço

  24. Deco says : Responder

    Olá,tem acessar cisco AP Aironet 1200 pelo browse diditando o IP?pois o ip dele não pinga?desde já agraço

  25. Ele pinga e dá sim para acessar via browser.
    Se quiser coloca ai a configuração.

  26. Wilder says : Responder

    Boa noite estou tentando acessar um roteador cisco 1242 que comprei novo e nao estou conseguindo, coloquei ele após um roteador na mesma rede que meu computador ele recebeu um ip do roteador 192.168.0.183 meu computador 192.168.0.162, eu consigo pingar normalmente, mais nao consigo acesso via navegador, o que poderia ser?

  27. Jean Carlo says : Responder

    Wilder, verifica os ips utilizando o comando ipconfig no prompt de comando ele vai puxar as configurações de ip usa o ip do gateway padrao no navegador o resto user/senha vai pelo manual do roteador

  28. Thank you for good wallpaper!

  29. Emerson says : Responder

    Qual seria o comando para testar se o acesso a WEB está funcionado num router Cisco.

    Grato
    Emerson

  30. Você quer configurar o roteador via browser? Se for basta você abrir um browser e digitar o IP do roteador. Pode tentar com http ou https.

  31. Emerson says : Responder

    Não. Eu quero saber se o acesso de internet esta funcionando sem ter um PC conectado na rede. Apenas dando um ping pelo router.

  32. Emerson, você dar um ping usando a interface interna (LAN)
    ping 8.8.8.8 source f0/1

    ou dar um telnet em uma página:
    telnet http://www.uol.com.br /source-interface f0/1

  33. Emerson says : Responder

    Andre, muito obrigado pela informação.

  34. assis says : Responder

    depois de digitar o comando copy r s, ele pede um caminho , qual é?

  35. Assis, basta dar enter.

  36. julio says : Responder

    Parabéns muito bom mais gostaria de vê mais comandos 🙂

  37. Obrigado Julio.
    Dá uma olhada pelo blog que você vai encontrar mais comandos, nos exemplos de configuração.

  38. everson says : Responder

    excelente publicação amigo, vc esta de parabens pelas dicas..

  39. Vinicius says : Responder

    Parabens a todos que retornaram para informar ao André que obteve sucesso. Isso ajudou a não realizar outro post fazendo a mesma pergunta. Obrigado.

  40. Pedro L says : Responder

    existe algum comando, com o qual eu possa identificar uma maquina através de seu endereço IP?

  41. Pedro, o que você quer dizer como identificar uma máquina? Se você já tem o IP…

  42. Bruno says : Responder

    Cara, esse fórum, me ajudou muito, espero poder colaborar também!!! abraços

  43. Renan says : Responder

    Cara, estou com um router CISCO RV042, consegui acessar as configurações dele ontem, porém, quando estava fuçando, por algum motivo ele saiu do ar. agora eu consigo acessar pelo IP 192.168.1.1, porém quando digito o login e a senha, o mesmo não carrega, mas também não diz que a senha está errada, como diz se eu digitar algo diferente do admin/admin. Oque devo fazer ???

    Obrigadoo

  44. Renan,
    tenta fazer o reset.
    Aperte o botão reset por 30 segundos. Assim ele deve voltar ao padrão de fábrica, com ip 192.168.1.1 e usuário e senha admin.
    Pode ser que ele resetou, mas alguma coisa não deu certo.

  45. Ricardo says : Responder

    Amigo Andre tenho um cisco rv042 vc tem a configuração dele que funcione bem jogos,msn,bancos etc.. pois aki num fica legal fora que quando coloco ele no mikrotik o mk fica pendendo o contato com o link vc pode me ajudar?

  46. Ricardo, faz muito tempo que não configuro um RV… me lembro apenas alguns tipos de conexões que usam SSL (como banco e jogos) não podem ser balanceados, pois a sessão é finalizada.
    Cadastre o IP/URL dos bancos para sair sempre pelo mesmo link.

    Se o problema for esse, faça o mesmo com sites de jogos.

  47. fabio says : Responder

    bom dia galera ,estou trabalhando com os roteadores da cisco e huawai e gostaria de saber se tem algum site que eu possa aprender a rotear e configurar eles pois sou tecnico de informatica mais nunca trabalhei com programaçao e sou totalmente leigo e gostaria de uma dica ok ,desde ja agradeço a atençao de vcs e fico no aguardo.abraços

  48. Fabio,
    precisa ver o que você quer configurar exatamente… tem muita informação disponível (pelo menos Cisco).

    Configurando rota estática:
    http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800ef7b2.shtml

    Configurando protocolo de roteamento:
    http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfrip.html

  49. Erminio says : Responder

    Alex como faço para descobrir o ip do roteador 2851, Preciso criar uma rotina de backup nele e pelo comando algumas vezes o arquivo está vindo corrompido. Ou você conhece outro método de se fazer backup do roteador. Agradeço desde já.

  50. Carlos says : Responder

    Qual o comando para apagar a configuração do router?

  51. Carlos, você quer apagar completamente a configuração??
    Use o comando erase startup-config, e então reinicie o equipamento SEM SALVAR.

  52. Elisio Panzo says : Responder

    Goste do post, visto que so pricipiante na área de cisco, acho que vou precisar de todo aquele experientes na área.

    quem for certificado CCNA explorer 4.0 preciso de interagir para me prepara para os exames que se a visinham.

    Luanda – Angola

  53. Cristina says : Responder

    Olá, estou com uma dúvida que talvez alguém aqui possa me ajudar a esclarecer, existe algum history que possa ser dado que se refira a todos os comandos dados e não somente os últimos como se verifica no sh history ??

  54. Taves says : Responder

    Olá,

    Gostaria de um auxílio,

    Estou com um catalyst 3560 – estou tentando acessar a interface web sem sucesso!
    Ele até devolve uma pagina padrão, inclusive com um LINK “Web console” mais não a interface web.
    Na tentativa de acessar a web console por este link – retorna – “Page not found”.

    Já tentei #ip http authentication enable” – sem exito.

    Alguma dica habilitar o acesso a interface web ?

    Grato,

    Taves

  55. Gabriel says : Responder

    Olá André, estou tendo um problema com um aironet 1600, pelo que vi ele está configurado por DHCP, em minha rede verifiquei através do MAC que ele estava com o IP 192.168.0.4 porem não consigo acessar seu menu de configuração através do browser.
    Outro problema que estou tendo é por acesso no Hyperterminal com um cabo Console, não consigo acessar o modo global
    ele aparece isso:

    AP1c6a.7a57.c134#configure terminal
    ^
    % Invalid input detected at ‘^’ marker.

    Obrigado.

    • Gabriel, provavelmente este access-point está com software “controller based”. Precisa trocar o software para trabalhar em modo autônomo e você poder configurá-lo.

  56. Amello says : Responder

    Tem como reiniciar um rv042 à distância? Tenho acesso ao roteador. A VPN caiu e não sobe. Reiniciar seria uma boa saída para testar. Obrigado

  57. daniel cardoso says : Responder

    como colocar 3 ips de lan na mesma interface.?

    • Daniel, basta usar a palavra “secondary” após o IP.
      Ex:
      int f0/0
      ip address 10.1.2.252 255.255.255.0
      ip address 10.1.3.252 255.255.255.0 secondary
      ip address 10.1.4.252 255.255.255.0 secondary

  58. Por que é necessário apagar a configuração de inicialização antes de recarregar o roteador

    • Olá Ed, não é necessário.
      Você faz isso quando quer apagar a configuração. Neste caso você apaga e reinicia o equipamento para ele ligar “zerado”.

  59. Almir Araujo says : Responder

    Caro amigo onde consigo os softwares show version e o show diag para o Cisco 2800 Series?

  60. BrDigital says : Responder

    gostaria de saber como subo a Flash no roteador cisco 1841.. alguém poderia me ajudar???

  61. Max says : Responder

    CISCO 1841

    SCRIPT P/CISCO 1841 CONFIGURADO OI VELOX IP DINAMICO?
    Esquema abaixo :
    modem roteador ZTE – 172.16.0.1 msk 255.255.255.0
    Roteador cisco 1841 -DHCP ip 192.168.1.1 mask 255.255.255.192
    Quero usar as portas fasethenet que tem no roteador F0/0 e F0/1.
    Moden ZTE -> Cisco 1841 portas Fast 0/0 ( velox ) e fast 0/1 ( rede ) ->Linksys w.
    Aceito qualquer configuração que funcione .
    alguém pode me ajudar se possivel

    • Só por curiosidade… Por que inserir mais um roteador no caminho?

      SE você configurasse o modem como bridge, e SE a conexão fosse PPPoE, o script poderia ser o abaixo:
      1. VPDN Group
      router#configure terminal
      Enter configuration commands, one per line. End with CNTL/Z.
      router(config)#vpdn enable
      router(config)#vpdn-group 1
      router(config-vpdn)#request-dialin
      router(config-vpdn)#protocol pppoe
      router(config-vpdn)#exit

      2. WAN interface
      router(config)#interface Ethernet1
      router(config-if)#description ADSL WAN Interface
      router(config-if)#no ip address
      router(config-if)#no ip redirects
      router(config-if)#no ip unreachables
      router(config-if)#no ip proxy-arp
      router(config-if)#no ip mroute-cache
      router(config-if)#pppoe enable
      router(config-if)#pppoe-client dial-pool-number 1
      router(config-if)#no cdp enable
      router(config-if)#ip tcp adjust-mss 1452
      router(config-if)#exit

      router(config)#interface Dialer1
      router(config-if)#description ADSL WAN Dialer
      router(config-if)#ip address negotiated
      router(config-if)#no ip unreachables
      router(config-if)#ip nat outside
      router(config-if)#encapsulation ppp
      router(config-if)#no ip mroute-cache
      router(config-if)#dialer pool 1
      router(config-if)#dialer-group 1
      router(config-if)#no cdp enable
      router(config-if)#ip mtu 1492
      router(config-if)#ip tcp adjust-mss 1452
      router(config-if)#ppp authentication chap pap callin
      router(config-if)#ppp chap hostname [USERNAME]
      router(config-if)#ppp chap password [PASSWORD]
      router(config-if)#ppp pap sent-username [USERNAME] password [PASSWORD]
      router(config-if)#exit

      3. Dialer-list
      router(config)#dialer-list 1 protocol ip permit

      4. LAN interface
      router(config)#interface Ethernet0
      router(config-if)#description LAN Interface
      router(config-if)#ip address 10.10.10.1 255.255.255.0
      router(config-if)#no ip redirects
      router(config-if)#no ip unreachables
      router(config-if)#no ip proxy-arp
      router(config-if)#ip nat inside
      router(config-if)#no ip mroute-cache
      router(config-if)#no cdp enable
      router(config-if)#exit

      5. NAT e Roteamento
      router(config)#access-list 10 permit 10.10.10.0 0.0.0.255
      router(config)#ip nat inside source list 10 interface Dialer1 overload
      router(config)#ip route 0.0.0.0 0.0.0.0 Dialer1

      • Max says : Responder

        Muito obrigado estava a madruga toda postando em grupos do FACE de suporte Cisco mais ninguém deu bola , enfim muito obrigado .

        O motivo do CISCO 1841 é por que estou no curso no SENAC RJ e quero ter ele na minha rede acho melhor , não entendi bem mais o modem é roteador certo sei disso mais ele é da borda tem como colocara a função do cisco 1841 no lugar do modem ?

        Agradeço sua ajuda caro amigo André Ortega

  62. Moisés Martins says : Responder

    To com dificuldades para liberar o acesso externo do meu servidor de ftp, já criei a regra no router:
    permit tcp any host xxx.xxx.xxx.xx eq ftp (136 matches)
    permit tcp any host xxx.xxx.xxx.xx eq ftp-data

    porém não funciona, alguma dica?

    • Moises, considerando-se que o IP do servidor FTP seja 192.168.1.100, e seu FTP trabalhe no modo ativo, faça a seguinte configuração.
      !
      access-list 102 permit tcp any host 192.168.1.100 eq ftp
      access-list 102 permit tcp any host 192.168.1.100 eq ftp-data established
      interface f0/0
      description INTERNET – FTP Client
      ip access-group 102 in
      !
      access-list 110 permit host 192.168.1.100 eq ftp any established
      access-list 110 permit host 192.168.1.100 eq ftp-data any
      !
      interface f0/1
      description LAN – FTP Server
      ip access-group 110 in
      !

      Como o roteador não é um statefull firewall, você precisa liberar a ida e a volta.
      Se o FTP Server for passivo, a configuração é diferente, sendo necessário liberar todas as portas acima de 1024 (o que é ruim…).

  63. alguem pode me ajudar?

  64. alguem pode me ajudar?Pois estou com dificuldades de instalar um cisco 1200 series? queria saber o que preciso fazer, se tiver como me ajudar passo a passo.

    desde já agradeço.

  65. bruna says : Responder

    eu preciso apagar as vlans criadas no meu switch cisco 1900,e nao estou conseguindo o reset so funcionou para apagar as senhas…queria zerar ele todo como faço me ajudem por favor

  66. Bianco says : Responder

    Olá André,
    Estou configurando um ap cisco aironet 2600.
    Consegui fazer a configuração de IP tanto para bv1 quando para GigaEthernet, conecto ele na minha rede e meus micros conectam nele e navegam. Até ok tudo bem,
    Meu problema está no DHCP, por mais que eu tenha feito a configuração de dhcp, ele está pegando o dhcp do meu servidor da rede ao invés do que setei nele. Tem como forçar ele a fazer o dhcp? pois eu quero que ele forneça outro range de ip, diferente do meu servidor: abaixo minha configuração dhcp:

    ip dhcp pool nomePool
    network 192.168.120.0 255.255.255.0
    default-router 192.168.120.11
    dns-server 192.168.0.11
    lease2

    O ip do meu ap é 192.168.120.11. Quero que ele forneça os ip do range de 192.168.120.1 até 192.168.120.254.

    Obrigado.

    • Olá Bianco, antes de mais nada lembre-se que este equipamento não é um roteador.
      Se ele fornecer ip diferente da sua rede os equipamentos não acessaram a rede e/ou internet. Ele também não pode ser o gateway, não funcionaria.
      Por que não usar o próprio servidor DHCP para isso?

  67. Existe possibilidade de usar um roteador cisco 1905 com o um switch?
    Desabilitando todo seu roteamento, acrescentando uma WIC 4ESW para ter mais 4 interfaces Eth, ficariam 2 interface Giga+ 4 eth.
    Motivo, tenho 2 desses parados e acredito que ele tenha um throughput e comporte um alto trafego em suas interfaces.

    • Everton,
      as portas da WIC 4ESW são portas layer 2 (switches), ou seja, se conectar esse modulo no roteador e conectar equipamentos nelas, eles vão se falar (estarão na mesma rede).
      As outras duas portas (nativas do roteador) também podem trabalhar em layer 2, mas precisam ser configuradas para isso, e ver se funcionará como você está imaginando.

  68. Rodrigo says : Responder

    Boa Noite, como faço para alterar licença do cisco 1905/k9??? Grato

  69. Robson Nascimento says : Responder

    CISCO 1921
    Sou iniciante em equipamentos cisco, estou a vários dias e noites tentando configura este router cisco 1921, pesquisando em diversos fóruns e artigos mas sem êxito.
    Este é o melhor fórum que encontrei, se possível poderiam me ajuda?

    MONTEI O SEGUINTE ESQUEMA PARA CONFIGURAÇÃO DO ROTEADO CISCO 1921.
    WAN – Interface G0/1 (link dedicado)
    IP: 177.55.171.160-164 255.255.255.248
    Gateway: 177.55.171.159
    DNS: 200.175.5.139 / 200.175.5.89

    LAN – interface G0/0 (LAN, DHCP, DNS e compartilhando de internet)
    IP: 192.168.25.1 255.255.255.0
    Range: 192.168.25.20 a 192.168.25.250 (reservando os primeiros IP para host fixo)
    DNS: 192.168.25.1 (Não tenho DNS na rede preciso configurar no roteador)

    Tenho instalado no router uma placa EHWIC 4ESEG com mas 4 portas link0-3x, como não tenho switcher e tenho que conectar dois APs e um File server posso configurar estas portas como Switchers da LAN G0/0.
    Se possível alguém poderia me ajudar com o script de configuração? aceito sugestões.

    Desde já meus agradecimento

  70. Ivan Pene says : Responder

    Parabéns, o artigo está fantástico. Mas eu estou com um problema, quando digito o comando ‘show ip route’ só aparece a Rede local LAN e nem sinal das WAN’s, mas configurei manualmente todas as rotas tanto LAN como WAN.

    C 192.168.4.0/24 is directly connected, FastEthernet0/0

  71. daronimo mendes says : Responder

    como configurar cisco 1905, pois sou iniciante neste equipamento , onde começar ? obrigado !

  72. Vinicius Ferreira says : Responder

    Bom dia Srs. Preciso da ajuda de vcs !!

    Tenho um router cisco small business RV042, sendo que qdo digito o ip (192.168.1.1) no navegador, não aparece a tela de setup para efetuar as configurações no mesmo.

    Configurei meu pc com ip (192.168.1.2) e tenho conectividade e pelo prompt ao digitar ping 192.168.1.1 tenho conectividade normalmente.

  73. roberto sousa says : Responder

    Olá. Alguém conhece algum comando no roteador cisco (IOS) para listar em realtime todos os IPs que estão trafegando por ele?q

  74. David says : Responder

    Preciso de ajuda eu preciso configurar o roteador cisco aironet 1200 series mais nem sei por onde começar me refiro nos cabos, programa para entrar na parte de configuração onde posso alterara o nome, ip, senha etc. Por favor preciso de ajuda pois só aqui que estou na esperança de conseguir pois já pesquisei vários sites dias e noites e não tive nenhum resultado. esse e meu e-mail: (**editado**)

  75. SchivaS says : Responder

    brother eu tenho um dslam ma5600 e a placa scub ta reiniciando no hyperterminal ta apresentando [SDRAM TEST ERROR] Addr: 0x00000000 Write: 0x00000000 Read: 0xFFFFEF77 o que eu posso fazer ?

  76. Euna says : Responder

    Bom dia,

    Parabéns pelo post, fiz exatamente como você falou:

    erase startup. Em seguida de o comando reload, e quando perguntou se queria salvar a configuração, digitei “N”.

    Mas depois disso o roteador ficou inacessível. Podes me ajudar?

  77. SchivaS says : Responder

    Basta vc setar na sua placa de rede um ip na mesma faixa que o roteador

  78. Valter says : Responder

    Gostaria de saber como posso configurar um cisco 1905 para trabalhar em Bridge?

  79. Uilton says : Responder

    boa tarde tenho dos router da cisco um 2801 e um 819 ambos nao salva as minha conf
    tem algo errado neles grato

  80. William Armstrong says : Responder

    Boa tarde.

    Estou com dificuldades para efetuar a configuração de um Cisco 1841 + Wic 1ADSL + Wic 4FE.
    Efetuei a sua configuração inicial. a interface ADSL deu Train up Line UP. mas após um reset ele não fica mais up.
    se vc coloca a mesma linha em um modem adsl comum sobe autentica normal. necessito também fazer a configuração da sessão NAT, e redirecionamento de DMZ ..

    Muito obrigado
    William
    Cisco IOS Software, 1841 Software (C1841-ADVENTERPRISEK9-M), Version 12.4(9)T5, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2007 by Cisco Systems, Inc.
    Compiled Thu 16-Aug-07 14:25 by prod_rel_team

    ROM: System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1)

    c1841 uptime is 23 minutes
    System returned to ROM by reload at 16:44:58 UTC Thu Dec 29 2016
    System image file is “flash:c1841-adventerprisek9-mz.124-9.T5.bin”

    Cisco 1841 (revision 5.0) with 117760K/13312K bytes of memory.
    Processor board ID FTX093XXXX
    6 FastEthernet interfaces
    1 ATM interface
    1 Virtual Private Network (VPN) Module
    DRAM configuration is 64 bits wide with parity disabled.
    191K bytes of NVRAM.
    62720K bytes of ATA CompactFlash (Read/Write)

    Configuration register is 0x2102

    sh run
    Current configuration : 6293 bytes
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname c1841
    !
    boot-start-marker
    boot-end-marker
    !
    security authentication failure rate 10 log
    security passwords min-length 6
    logging buffered 4096 debugging
    logging console critical
    enable secret 5
    enable password 7
    !
    aaa new-model
    !
    !
    aaa authentication login local_auth local
    !
    aaa session-id common
    !
    resource policy
    !
    no ip source-route
    no ip gratuitous-arps
    ip cef
    !
    !
    !
    !
    no ip bootp server
    ip domain name biosystems
    ip name-server 8.8.8.8
    ip name-server 10.141.0.5
    ip ssh time-out 60
    ip ssh authentication-retries 2
    ip inspect audit-trail
    ip inspect udp idle-time 1800
    ip inspect dns-timeout 7
    ip inspect tcp idle-time 14400
    ip inspect name autosec_inspect cuseeme timeout 3600
    ip inspect name autosec_inspect ftp timeout 3600
    ip inspect name autosec_inspect http timeout 3600
    ip inspect name autosec_inspect rcmd timeout 3600
    ip inspect name autosec_inspect realaudio timeout 3600
    ip inspect name autosec_inspect tftp timeout 30
    ip inspect name autosec_inspect udp timeout 15
    ip inspect name autosec_inspect tcp timeout 3600
    ip ips sdf location flash://attack-drop.sdf
    ip ips sdf location flash://128MB.sdf
    ip ips notify SDEE
    ip ips name sdm_ips_rule
    login block-for 15 attempts 5 within 1
    !
    !
    crypto pki trustpoint TP-self-signed-1861087183
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1861087183
    revocation-check none
    rsakeypair TP-self-signed-1861087183
    !
    !
    crypto pki certificate chain TP-self-signed-1861087183
    certificate self-signed 01
    3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
    31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
    69666963 6174652D 31383631 30383731 3833301E 170D3136 30343234 30313434
    32335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
    2B71F989 0AEE0DCD 9B1A1606 95E41851 102344D8 984FC274 38B350CE A5D2EEE7
    9FA30203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
    551D1104 1B301982 17633138 34312E62 696F7379 7374656D 732E6174 682E6378
    301F0603 551D2304 18301680 146E6B74 F4D00D78 314FCB39 9309F531 D93900E4
    3D301D06 03551D0E 04160414 6E6B74F4 D00D7831 4FCB3993 09F531D9 3900E43D
    300D0609 2A864886 F70D0101 04050003 8181006D 746C2F81 E93B5325 F8A884C2
    30AF2287 A5C25860 49FB24D8 6952A91E 5AB2CF94 9A011667 931A8B3D C5064113
    87D5879D 4B239773 55608E2E 246F88D2 9CA9AF7D 8DE99F6D 8F0FEAB8 6885B237
    C1DA894B 6A2C7A36 20CC6B42 5DE56025 A7445A8B AEBFDD3C 9A80BDE7 56907EFC
    941BBA28 BCFB8999 743FBE60 CF607230 86742D
    quit
    username ti password 7
    username bio privilege 15 password 7
    username enable privilege 15 password 7
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    description $ETH-LAN$
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    shutdown
    speed auto
    full-duplex
    no mop enabled
    !
    interface FastEthernet0/1
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    shutdown
    speed auto
    full-duplex
    no mop enabled
    !
    interface FastEthernet0/1/0
    switchport access vlan 200
    switchport trunk native vlan 200
    no mop enabled
    !
    interface FastEthernet0/1/1
    shutdown
    !
    interface FastEthernet0/1/2
    shutdown
    !
    interface FastEthernet0/1/3
    shutdown
    !
    interface ATM0/0/0
    no ip address
    ip access-group autosec_firewall_acl in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip inspect autosec_inspect out
    no atm ilmi-keepalive
    bundle-enable
    dsl operating-mode auto
    dsl enable-training-log
    hold-queue 224 in
    pvc 0/35
    pppoe-client dial-pool-number 1
    !
    !
    interface Vlan1
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    shutdown
    no mop enabled
    !
    interface Vlan200
    description $ES_LAN$
    ip address 192.168.200.1 255.255.255.0
    ip nat inside
    ip ips sdm_ips_rule out
    ip virtual-reassembly
    !
    interface Dialer0
    ip address negotiated
    ip mtu 1492
    ip nat outside
    ip ips sdm_ips_rule in
    ip ips sdm_ips_rule out
    ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    no cdp enable
    ppp chap hostname oi@oi
    ppp chap password 7 030B52
    ppp pap sent-username oi@oi password 7 094347
    ppp ipcp dns request accept
    !
    router ospf 200
    log-adjacency-changes
    passive-interface Vlan200
    network 192.168.200.0 0.0.0.255 area 0.0.0.2
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 10.141.0.0 255.255.252.0 192.168.200.254
    ip route 192.168.200.0 255.255.255.0 FastEthernet0/1/0
    ip route 192.168.200.1 255.255.255.255 FastEthernet0/1/0
    !
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat inside source list NAT interface Dialer0 overload
    !
    ip access-list standard NAT
    permit 0.0.0.0 255.255.255.0
    !
    ip access-list extended autosec_firewall_acl
    permit udp any any eq bootpc
    deny ip any any
    !
    logging trap debugging
    logging facility local2
    access-list 42 permit any
    access-list 100 permit udp any any eq bootpc
    access-list 101 permit udp any any eq bootpc
    access-list 102 permit udp any any eq bootpc
    dialer-list 1 protocol ip permit
    dialer-list 1 protocol ipx permit
    snmp-server view NMIS8RO iso included
    snmp-server community NMISreadView view NMIS8RO RO 42
    snmp-server community NMISread RO 42
    snmp-server community public RO
    snmp-server location Curitiba – Parana – Brazil
    snmp-server contact NMIS bio@biosystems
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    banner motd ^C BSSN ^C
    !
    line con 0
    exec-timeout 5 0
    login authentication local_auth
    transport output telnet
    line aux 0
    exec-timeout 15 0
    login authentication local_auth
    transport output telnet
    line vty 0 4
    login authentication local_auth
    transport input telnet ssh
    !
    scheduler allocate 20000 1000
    end

      • William Armstrong says : Responder

        Obrigado pela resposta.

        O post explica como criar um concentrador PPPoE, no caso o DSLAM no meu caso eu necessitaria o CPE.

        Achei o ponto de erro.

        !
        dsl operating-mode auto
        dsl enable-training-log
        pvc 0/35
        encapsulation aal5snap
        !
        !

        !
        interface ATM0/0/0
        no ip address
        ip access-group autosec_firewall_acl in
        no ip redirects
        no ip unreachables
        no ip proxy-arp
        ip inspect autosec_inspect out
        atm bandwidth dynamic
        no atm ilmi-keepalive
        dsl operating-mode itu-dmt
        dsl enable-training-log
        dsl lom 30
        hold-queue 224 in
        pvc 0/35
        encapsulation aal5snap
        pppoe-client dial-pool-number 1
        !
        !
        selecionando a opção dsl operating-mode itu-dmt para forçar a ele somente utilizar esta ele sincronizou.
        autenticou e obteve conectividade IP.
        c1841>ping uol.com.br
        Translating “uol.com.br”…domain server (8.8.8.8) [OK]

        Type escape sequence to abort.
        Sending 5, 100-byte ICMP Echos to 2804:49C:3103:401:FFFF:FFFF:FFFF:1, timeout is 2 seconds:

        % No valid source address for destination
        c1841>ping 201.22.59.130

        Type escape sequence to abort.
        Sending 5, 100-byte ICMP Echos to 201.22.59.130, timeout is 2 seconds:
        !!!!!
        Success rate is 100 percent (5/5), round-trip min/avg/max = 36/39/52 ms

        Dialer0 is up, line protocol is up
        Internet address is 200.138.152.136/32
        Broadcast address is 255.255.255.255
        Address determined by IPCP
        MTU is 1492 bytes
        Helper address is not set
        Directed broadcast forwarding is disabled
        Outgoing access list is sdm_dialer0_out
        Inbound access list is 104
        Proxy ARP is enabled
        Local Proxy ARP is disabled
        Security level is default
        Split horizon is enabled
        ICMP redirects are always sent
        ICMP unreachables are always sent
        ICMP mask replies are never sent
        IP fast switching is enabled
        IP fast switching on the same interface is enabled
        IP Flow switching is disabled
        IP CEF switching is enabled
        IP CEF Feature Fast switching turbo vector
        IP multicast fast switching is enabled
        IP multicast distributed fast switching is disabled
        IP route-cache flags are Fast, CEF
        Router Discovery is disabled
        IP output packet accounting is disabled
        IP access violation accounting is disabled
        TCP/IP header compression is disabled
        RTP/IP header compression is disabled
        Policy routing is disabled
        Network address translation is enabled, interface in domain outside
        BGP Policy Mapping is disabled
        WCCP Redirect outbound is disabled
        WCCP Redirect inbound is disabled
        WCCP Redirect exclude is disabled
        Outgoing inspection rule is SDM_MEDIUM
        Outgoing IPS rule is sdm_ips_rule
        Inbound IPS rule is sdm_ips_rule

        Mas me enrosquei com o nat. PAT
        utilizando a ferramenta CISCO SDM.

        efetuei uma configuração mas sem sucesso.

        Estou com a mesma situação com um roteador Cisco 1905 com uma ehwic 3G efetuei toda a configuração mas não consigo efetuar o nat. nem o PAT.

  81. charles says : Responder

    Alo pessoal,

    Estou com problema no meu roteador 1941 cisco, queria apagar as configuracoes nameroria NVRAM e digitei erase nvram e depois reload, ja não consigo conetar o router via porta console. Estou muito aflito porque a empresa não esta a produzir.

    • Por que não tem mais acesso a console? O roteador não liga? Não da nenhum output?
      Sem console não da para fazer muita coisa… E o problema deve ser outro (provavelmente hardware), já que o erase nvram não devia fazer você perder acesso a console.

  82. Luis says : Responder

    Ola, se eu alterar uma configuração em um equipamento cisco (um firewall), e não salvar. Essa configuração fica salva na sh running ou na startup? Pois como funciona mesmo? Eu queria tirar um backup mas sem salvar para caso de pau e voltar como estava.

Deixe uma resposta

TOP